Logo-small

6.21 Glorp

Generic Lightweight Object Relational Persistence. Glorp is an object-relational database mapping library similar to TopLink, Apple EOF, Hibernate, Cayenne and so on. Queries can be written using Smalltalk block syntax.

Basic Glorp

Glorp works only with Postgres databases. You have to install PostgreClientV2. If you have md5 in PostgreSQL you must also download Cryptography package.

Before install, allow underscore assingment via Settings.

Download Glorp, PostgreClientV2 and Cryptography packages in squeaksource via Monticello.

TODO: build a metacello configuration

GlorpDBX

A Glorp based library that doesn't depends on a particular database driver. This change is now in SqueakDBX repo (it will then be in Glorp repo) with the name of GlorpDBX. So, if you download GlorpDBX you won't require PostgreSQL native driver, but SqueakDBX. You can also download only Glorp and use another driver. All of this stuff (GlorpDBX) is still in development and only works with PostgreSQL, Oracle, MySql and MSSql

Gofer new
squeaksource: 'MetacelloRepository';
package: 'ConfigurationOfGlorpDBX';
load.
((Smalltalk at: #ConfigurationOfGlorpDBX) project version: '1.1') load

http://www.glorp.org/index.html

http://www.squeakdbx.org/Installation

Add a Note

Licensed under Creative Commons BY-NC-SA | Published using Pier |